about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix37
1 files changed, 35 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index d2c4c45..17cd5ce 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,3 +1,36 @@
-{ system ? builtins.currentSystem }:
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs {
+      overlays = [
+        (import "${sources.gomod2nix}/overlay.nix")
+      ];
+    }
+  )
+}:
+let
+  goEnv = pkgs.mkGoEnv { pwd = ./.; };
+  inherit (import ./.) pre-commit-check;
+in
+pkgs.mkShell {
+  inherit (pre-commit-check) shellHook;
+  packages = with pkgs; [
+    goEnv
 
-(builtins.getFlake (toString ./.)).devShells.${system}.default
+    npins
+    gopls
+    gotools
+    go-tools
+    gci
+    hyperlink
+    systemfd
+    just
+    modd
+
+    skopeo
+    flyctl
+    nodePackages.vercel
+    netlify-cli
+  ];
+}