about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-18 12:20:06 +0200
committerAlan Pearce2024-06-18 12:22:12 +0200
commitcf0da6d13edc55c003564f31d56a659cfa681e0c (patch)
treefc39a25b1a69b7922106b538c80fc2ecd9bb08ae /shell.nix
parentf690e8cb7a820b0685b98f83a6761cfc169487e4 (diff)
downloadwebsite-cf0da6d13edc55c003564f31d56a659cfa681e0c.tar.lz
website-cf0da6d13edc55c003564f31d56a659cfa681e0c.tar.zst
website-cf0da6d13edc55c003564f31d56a659cfa681e0c.zip
remove flake and docker setup
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix37
1 files changed, 35 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index d2c4c45..17cd5ce 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,3 +1,36 @@
-{ system ? builtins.currentSystem }:
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs {
+      overlays = [
+        (import "${sources.gomod2nix}/overlay.nix")
+      ];
+    }
+  )
+}:
+let
+  goEnv = pkgs.mkGoEnv { pwd = ./.; };
+  inherit (import ./.) pre-commit-check;
+in
+pkgs.mkShell {
+  inherit (pre-commit-check) shellHook;
+  packages = with pkgs; [
+    goEnv
 
-(builtins.getFlake (toString ./.)).devShells.${system}.default
+    npins
+    gopls
+    gotools
+    go-tools
+    gci
+    hyperlink
+    systemfd
+    just
+    modd
+
+    skopeo
+    flyctl
+    nodePackages.vercel
+    netlify-cli
+  ];
+}