about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..8f89178
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,22 @@
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs { }
+  )
+}:
+let
+  inherit (import ./.) pre-commit-check;
+in
+pkgs.mkShell {
+  inherit (pre-commit-check) shellHook;
+  packages = with pkgs; [
+    go
+    npins
+    gopls
+    go-licenses
+    gotools
+    templ
+    just
+  ];
+}