about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-30 11:36:16 +0200
committerAlan Pearce2024-06-30 11:36:16 +0200
commitddadac45203f8aa48b05e9944cc5dcddb8829f62 (patch)
tree39c548ec9b5eb2eac70df2c70e41c7d3a3e0756c /shell.nix
downloadx-ddadac45203f8aa48b05e9944cc5dcddb8829f62.tar.lz
x-ddadac45203f8aa48b05e9944cc5dcddb8829f62.tar.zst
x-ddadac45203f8aa48b05e9944cc5dcddb8829f62.zip
initial commit
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..8f89178
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,22 @@
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs { }
+  )
+}:
+let
+  inherit (import ./.) pre-commit-check;
+in
+pkgs.mkShell {
+  inherit (pre-commit-check) shellHook;
+  packages = with pkgs; [
+    go
+    npins
+    gopls
+    go-licenses
+    gotools
+    templ
+    just
+  ];
+}