about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix28
1 files changed, 25 insertions, 3 deletions
diff --git a/shell.nix b/shell.nix
index d2c4c45..5ccedea 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,3 +1,25 @@
-{ system ? builtins.currentSystem }:
-
-(builtins.getFlake (toString ./.)).devShells.${system}.default
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs { }
+  )
+}:
+let
+  inherit (import ./.) pre-commit-check;
+in
+pkgs.mkShell {
+  inherit (pre-commit-check) shellHook;
+  packages = with pkgs; [
+    go_1_23
+    npins
+    gopls
+    go-licenses
+    gotools
+    templ
+    hyperlink
+    systemfd
+    just
+    modd
+  ];
+}