about summary refs log tree commit diff stats
path: root/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nix/default.nix b/nix/default.nix
index a04131b..e6102cf 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -28,6 +28,7 @@ rec {
   builder = pkgs.buildGoApplication {
     pname = "website-builder";
     inherit version;
+    CGO_ENABLED = 0;
     src = with pkgs.lib.fileset; toSource {
       root = ./..;
       fileset = unions [
@@ -57,7 +58,7 @@ rec {
         ./../templates
       ];
     };
-    buildInputs = [ builder ];
+    nativeBuildInputs = [ builder ];
     prePatch = ''
       ${builder}/bin/build
     '';