about summary refs log tree commit diff stats
path: root/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nix/default.nix b/nix/default.nix
index 4299676..32c546f 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -14,7 +14,7 @@ let
         public
       ];
       config = {
-        Cmd = [ "${server}/bin/website" ];
+        Cmd = [ "${server}/bin/server" ];
         Env = [
           "PRODUCTION=true"
           "LISTEN_ADDRESS=::"
@@ -39,7 +39,7 @@ with pkgs; rec {
       fileset = unions [
         ./../go.mod
         ./../go.sum
-        ./../cmd
+        ./../cmd/build
         ./../internal
       ];
     };
@@ -61,7 +61,7 @@ with pkgs; rec {
     ${builder}/bin/build -s $src -d $out/public
   '';
   server = buildGoApplication {
-    pname = "website";
+    pname = "server";
     inherit version;
     CGO_ENABLED = 0;
     src = with lib.fileset; toSource {
@@ -69,7 +69,7 @@ with pkgs; rec {
       fileset = unions [
         ./../go.mod
         ./../go.sum
-        ./../server.go
+        ./../cmd/server
         ./../internal
       ];
     };