about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 2 insertions, 22 deletions
diff --git a/flake.nix b/flake.nix
index dec5e4d..67bcc1f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,14 +1,13 @@
 {
   description = "My website, alanpearce.eu";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-  inputs.flockenzeit.url = "github:balsoft/Flockenzeit";
   inputs.flake-utils.url = "github:numtide/flake-utils";
   inputs.flake-compat = {
     url = "github:edolstra/flake-compat";
     flake = false;
   };
 
-  outputs = { self, nixpkgs, flockenzeit, flake-utils, ... }:
+  outputs = { nixpkgs, flake-utils, ... }:
     flake-utils.lib.eachDefaultSystem
       (system:
         let
@@ -23,31 +22,12 @@
           ];
         in
         rec {
-          packages = {
-            default = pkgs.stdenv.mkDerivation {
-              name = "alanpearce.eu";
-              src = self;
-
-              enableParallelBuilding = true;
-              makeFlags = [ "PREFIX=$(out)/public" ];
-
-              inherit nativeBuildInputs;
-
-              dontFixup = true;
-            };
-            docker = import ./docker.nix {
-              inherit self pkgs flockenzeit;
-              website = packages.default;
-            };
-          };
           devShells = {
             default = pkgs.mkShell {
               packages = with pkgs; [
                 bun
                 flyctl
-              ] ++ nativeBuildInputs ++ (with pkgs.nodePackages; [
-                prettier
-              ]);
+              ] ++ nativeBuildInputs;
             };
           };
         });