about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/flake.nix b/flake.nix
deleted file mode 100644
index 67bcc1f..0000000
--- a/flake.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{
-  description = "My website, alanpearce.eu";
-  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-  inputs.flake-utils.url = "github:numtide/flake-utils";
-  inputs.flake-compat = {
-    url = "github:edolstra/flake-compat";
-    flake = false;
-  };
-
-  outputs = { nixpkgs, flake-utils, ... }:
-    flake-utils.lib.eachDefaultSystem
-      (system:
-        let
-          pkgs = nixpkgs.legacyPackages.${system};
-          nativeBuildInputs = with pkgs; [
-            nodePackages.prettier
-            fd
-            brotli
-            gzip
-            zstd
-            git
-          ];
-        in
-        rec {
-          devShells = {
-            default = pkgs.mkShell {
-              packages = with pkgs; [
-                bun
-                flyctl
-              ] ++ nativeBuildInputs;
-            };
-          };
-        });
-}