about summary refs log tree commit diff stats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/default.nix b/default.nix
index 4c29731..31f6b91 100644
--- a/default.nix
+++ b/default.nix
@@ -15,9 +15,6 @@ let
 
   version = "unstable";
   mkDocker = type: { server, website }:
-    let
-      PORT = 80;
-    in
     pkgs.dockerTools.${type} {
       name = "registry.fly.io/alanpearce-eu";
       config = {
@@ -25,11 +22,12 @@ let
         Env = [
           "PRODUCTION=true"
           "LISTEN_ADDRESS=::"
-          "PORT=${builtins.toString PORT}"
-          "ROOT=${website}"
+          "ROOT=."
+          "PORT=80"
         ];
+        WorkingDir = website;
         ExposedPorts = {
-          "${builtins.toString PORT}/tcp" = { };
+          "80/tcp" = { };
         };
       };
     };
@@ -90,6 +88,7 @@ rec {
       };
     } ''
     ${builder}/bin/build -s $src -d $out
+    cp $src/config.toml $out/
   '';
   server = buildGoApplication {
     pname = "server";