about summary refs log tree commit diff stats
path: root/ci.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ci.nix')
-rw-r--r--ci.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/ci.nix b/ci.nix
new file mode 100644
index 0000000..33b514d
--- /dev/null
+++ b/ci.nix
@@ -0,0 +1,18 @@
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs { }
+  )
+}:
+pkgs.mkShell {
+  packages = with pkgs; [
+    go
+    templ
+    hyperlink
+    just
+
+    ko
+    flyctl
+  ];
+}