about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-25 18:02:18 +0200
committerAlan Pearce2024-06-25 18:09:28 +0200
commit398210c8ce4140de12720d3f16cc88284a146005 (patch)
tree2d8144b52870c97f8cd9b86738fd51b50cda0bf5 /shell.nix
parentcd1125a213d742b5a89e8b60f0c7aafef13b8783 (diff)
downloadwebsite-398210c8ce4140de12720d3f16cc88284a146005.tar.lz
website-398210c8ce4140de12720d3f16cc88284a146005.tar.zst
website-398210c8ce4140de12720d3f16cc88284a146005.zip
build with ko instead of nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index 3b81469..6df4230 100644
--- a/shell.nix
+++ b/shell.nix
@@ -2,23 +2,15 @@
     let
       sources = import ./npins;
     in
-    import sources.nixpkgs {
-      overlays = [
-        (import "${sources.gomod2nix}/overlay.nix")
-      ];
-    }
+    import sources.nixpkgs { }
   )
 }:
 let
-  goEnv = pkgs.mkGoEnv { pwd = ./.; };
   inherit (import ./.) pre-commit-check;
 in
 pkgs.mkShell {
   inherit (pre-commit-check) shellHook;
   packages = with pkgs; [
-    goEnv
-    gomod2nix
-
     npins
     gopls
     gotools
@@ -30,7 +22,7 @@ pkgs.mkShell {
     just
     modd
 
-    skopeo
+    ko
     flyctl
     nodePackages.vercel
     netlify-cli