about summary refs log tree commit diff stats
path: root/ci.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-06-28 17:07:57 +0200
committerAlan Pearce2024-06-28 17:08:44 +0200
commit313f62584d7e5b59b9322442d0ee07a7526a0324 (patch)
tree44dc052ec184e0376c469e12a14abbf9a1f5e096 /ci.nix
parente29149ae9b0cd31f38beb38b0f4ea4e1599f4d93 (diff)
downloadwebsite-313f62584d7e5b59b9322442d0ee07a7526a0324.tar.lz
website-313f62584d7e5b59b9322442d0ee07a7526a0324.tar.zst
website-313f62584d7e5b59b9322442d0ee07a7526a0324.zip
use a smaller shell for CI
Diffstat (limited to 'ci.nix')
-rw-r--r--ci.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/ci.nix b/ci.nix
new file mode 100644
index 0000000..33b514d
--- /dev/null
+++ b/ci.nix
@@ -0,0 +1,18 @@
+{ pkgs ? (
+    let
+      sources = import ./npins;
+    in
+    import sources.nixpkgs { }
+  )
+}:
+pkgs.mkShell {
+  packages = with pkgs; [
+    go
+    templ
+    hyperlink
+    just
+
+    ko
+    flyctl
+  ];
+}