summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
new file mode 100644
index 00000000..6ebd3add
--- /dev/null
+++ b/user/settings/fish.nix
@@ -0,0 +1,19 @@
+{ pkgs
+, ...
+}: {
+  programs.fish = {
+    enable = true;
+    plugins = [
+      {
+        name = "tide";
+        src = pkgs.fetchFromGitHub {
+          # https://github.com/IlanCosman/tide
+          owner = "IlanCosman";
+          repo = "tide";
+          rev = "a3426e157f94b8a9cb5bcf96946b1e55625a1948";
+          sha256 = "1fwqmsrd6bpf67rgj6f362abjmpk6q8yynyskc4niwg3g15diqq5";
+        };
+      }
+    ];
+  };
+}