summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-16 21:02:13 +0200
committerAlan Pearce2023-08-16 21:04:50 +0200
commite6cc62fdc2f5e1c978dc875fd27fb023bb3f5c7b (patch)
tree62fedaf29e23d2358f3827f7f17e64fe70d30b9b /user/settings/fish.nix
parented692b6bfe0bef5769ce202cd690e5e35718ceee (diff)
downloadnixfiles-e6cc62fdc2f5e1c978dc875fd27fb023bb3f5c7b.tar.lz
nixfiles-e6cc62fdc2f5e1c978dc875fd27fb023bb3f5c7b.tar.zst
nixfiles-e6cc62fdc2f5e1c978dc875fd27fb023bb3f5c7b.zip
Switch to fish shell
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
new file mode 100644
index 00000000..6ebd3add
--- /dev/null
+++ b/user/settings/fish.nix
@@ -0,0 +1,19 @@
+{ pkgs
+, ...
+}: {
+  programs.fish = {
+    enable = true;
+    plugins = [
+      {
+        name = "tide";
+        src = pkgs.fetchFromGitHub {
+          # https://github.com/IlanCosman/tide
+          owner = "IlanCosman";
+          repo = "tide";
+          rev = "a3426e157f94b8a9cb5bcf96946b1e55625a1948";
+          sha256 = "1fwqmsrd6bpf67rgj6f362abjmpk6q8yynyskc4niwg3g15diqq5";
+        };
+      }
+    ];
+  };
+}