summary refs log tree commit diff stats
path: root/user/lima.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/lima.nix')
-rw-r--r--user/lima.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/lima.nix b/user/lima.nix
new file mode 100644
index 00000000..3ef47c65
--- /dev/null
+++ b/user/lima.nix
@@ -0,0 +1,24 @@
+{ pkgs, ... }:
+{
+  imports = [
+    ./modules/tabnine.nix
+    ./settings/base.nix
+    ./settings/development/base.nix
+    ./settings/git.nix
+    ./settings/nix.nix
+    ./settings/nixos.nix
+    ./settings/ssh.nix
+    ./settings/zsh.nix
+  ];
+  home = {
+    username = "alan";
+    homeDirectory = "/home/alan.linux";
+    stateVersion = "22.11";
+  };
+  # home-manager complains when setting nix.conf otherwise
+  nix.package = pkgs.nix;
+  nix.settings = {
+    max-jobs = 4;
+    experimental-features = "nix-command flakes";
+  };
+}