summary refs log tree commit diff stats
path: root/user/lima.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-07-23 09:10:18 +0200
committerAlan Pearce2023-07-23 09:10:18 +0200
commitf99c69a24094f471bb48a9eb60994e9118da884b (patch)
tree2b70c2997a93f179562a56c8eb9eca15d77f8d2e /user/lima.nix
parent4a6d5f251eba3203295a09a44b3a9c86ed3c999d (diff)
downloadnixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.tar.lz
nixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.tar.zst
nixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.zip
Set up lima VM running nixos
Diffstat (limited to 'user/lima.nix')
-rw-r--r--user/lima.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/user/lima.nix b/user/lima.nix
new file mode 100644
index 00000000..3ef47c65
--- /dev/null
+++ b/user/lima.nix
@@ -0,0 +1,24 @@
+{ pkgs, ... }:
+{
+  imports = [
+    ./modules/tabnine.nix
+    ./settings/base.nix
+    ./settings/development/base.nix
+    ./settings/git.nix
+    ./settings/nix.nix
+    ./settings/nixos.nix
+    ./settings/ssh.nix
+    ./settings/zsh.nix
+  ];
+  home = {
+    username = "alan";
+    homeDirectory = "/home/alan.linux";
+    stateVersion = "22.11";
+  };
+  # home-manager complains when setting nix.conf otherwise
+  nix.package = pkgs.nix;
+  nix.settings = {
+    max-jobs = 4;
+    experimental-features = "nix-command flakes";
+  };
+}