summary refs log tree commit diff stats
path: root/system/settings/programs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/settings/programs/shell.nix')
-rw-r--r--system/settings/programs/shell.nix24
1 files changed, 16 insertions, 8 deletions
diff --git a/system/settings/programs/shell.nix b/system/settings/programs/shell.nix
index bf8fc3aa..6f4b793a 100644
--- a/system/settings/programs/shell.nix
+++ b/system/settings/programs/shell.nix
@@ -1,11 +1,19 @@
-{ config, pkgs, ... }:
-
 {
-  programs.zsh = {
-    enable = true;
-    promptInit = "";
-  } // (if pkgs.stdenv.isDarwin then {} else {
-    enableGlobalCompInit = false;
-  });
+  config,
+  pkgs,
+  ...
+}: {
+  programs.zsh =
+    {
+      enable = true;
+      promptInit = "";
+    }
+    // (
+      if pkgs.stdenv.isDarwin
+      then {}
+      else {
+        enableGlobalCompInit = false;
+      }
+    );
   programs.bash.enableCompletion = true;
 }