summary refs log tree commit diff stats
path: root/system/settings/programs/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /system/settings/programs/shell.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'system/settings/programs/shell.nix')
-rw-r--r--system/settings/programs/shell.nix24
1 files changed, 16 insertions, 8 deletions
diff --git a/system/settings/programs/shell.nix b/system/settings/programs/shell.nix
index bf8fc3aa..6f4b793a 100644
--- a/system/settings/programs/shell.nix
+++ b/system/settings/programs/shell.nix
@@ -1,11 +1,19 @@
-{ config, pkgs, ... }:
-
 {
-  programs.zsh = {
-    enable = true;
-    promptInit = "";
-  } // (if pkgs.stdenv.isDarwin then {} else {
-    enableGlobalCompInit = false;
-  });
+  config,
+  pkgs,
+  ...
+}: {
+  programs.zsh =
+    {
+      enable = true;
+      promptInit = "";
+    }
+    // (
+      if pkgs.stdenv.isDarwin
+      then {}
+      else {
+        enableGlobalCompInit = false;
+      }
+    );
   programs.bash.enableCompletion = true;
 }