summary refs log tree commit diff stats
path: root/system/modules/nextdns.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/nextdns.nix')
-rw-r--r--system/modules/nextdns.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/system/modules/nextdns.nix b/system/modules/nextdns.nix
index b6e33728..0c718d57 100644
--- a/system/modules/nextdns.nix
+++ b/system/modules/nextdns.nix
@@ -1,13 +1,18 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+with lib; let
   inherit (pkgs) stdenv;
 
   cfg = config.networking.nextdns;
 
-  identifyingPrefix = if cfg.identifyDevice then "${config.networking.hostName}-" else "";
+  identifyingPrefix =
+    if cfg.identifyDevice
+    then "${config.networking.hostName}-"
+    else "";
 
   kresdConfig = {
     enable = true;
@@ -31,8 +36,7 @@ let
       })))
     '';
   };
-in
-{
+in {
   options = {
     networking.nextdns.enable = mkOption {
       type = types.bool;
@@ -55,7 +59,6 @@ in
   };
 
   config = mkIf cfg.enable {
-
     assertions = [
       {
         assertion = !(stdenv.isDarwin);