summary refs log tree commit diff stats
path: root/system/modules/nextdns.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-10-16 23:49:18 +0200
committerAlan Pearce2022-10-16 23:56:07 +0200
commit05dd85210e465caa44ef7254f2781b2d12ba2882 (patch)
tree85ccc720e339dd5ca8d7eb3ce6a3488c78675235 /system/modules/nextdns.nix
parent472dbbdbb246cf3d8ce3a5c3c6cefaa07b7589df (diff)
downloadnixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.lz
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.tar.zst
nixfiles-05dd85210e465caa44ef7254f2781b2d12ba2882.zip
Reformat files with alejandra
Diffstat (limited to 'system/modules/nextdns.nix')
-rw-r--r--system/modules/nextdns.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/system/modules/nextdns.nix b/system/modules/nextdns.nix
index b6e33728..0c718d57 100644
--- a/system/modules/nextdns.nix
+++ b/system/modules/nextdns.nix
@@ -1,13 +1,18 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+with lib; let
   inherit (pkgs) stdenv;
 
   cfg = config.networking.nextdns;
 
-  identifyingPrefix = if cfg.identifyDevice then "${config.networking.hostName}-" else "";
+  identifyingPrefix =
+    if cfg.identifyDevice
+    then "${config.networking.hostName}-"
+    else "";
 
   kresdConfig = {
     enable = true;
@@ -31,8 +36,7 @@ let
       })))
     '';
   };
-in
-{
+in {
   options = {
     networking.nextdns.enable = mkOption {
       type = types.bool;
@@ -55,7 +59,6 @@ in
   };
 
   config = mkIf cfg.enable {
-
     assertions = [
       {
         assertion = !(stdenv.isDarwin);