summary refs log tree commit diff stats
path: root/system/modules/darwin/kresd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system/modules/darwin/kresd.nix')
-rw-r--r--system/modules/darwin/kresd.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/system/modules/darwin/kresd.nix b/system/modules/darwin/kresd.nix
deleted file mode 100644
index 6bce8af1..00000000
--- a/system/modules/darwin/kresd.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-  cfg = config.services.kresd;
-  package = pkgs.knot-resolver;
-
-  configFile = pkgs.writeText "kresd.conf" cfg.extraConfig;
-in
-{
-  options = {
-    services.kresd.enable = mkOption {
-      type = types.bool;
-      default = false;
-      description = "Whether to enable knot-resolver daemon.";
-    };
-
-    services.kresd.extraConfig = mkOption {
-      type = types.lines;
-      default = "";
-      description = ''
-        Extra configuration to be added to the generated configuration file.
-      '';
-    };
-  };
-
-  config = mkIf cfg.enable {
-    launchd.daemons.kresd = {
-      command = "${package}/bin/kresd -c ${configFile}";
-
-      serviceConfig = {
-        ProcessType = "Interactive";
-        # Sockets = {
-        #   Listeners = {
-        #     SockServiceName = "dns";
-        #     SockFamily = "IPv4";
-        #   };
-        # };
-      };
-    };
-
-    environment.systemPackages = [ package ];
-  };
-}