summary refs log tree commit diff stats
path: root/system/modules/darwin/kresd.nix
diff options
context:
space:
mode:
authorAlan Pearce2020-09-10 14:57:15 +0200
committerAlan Pearce2020-09-10 14:57:15 +0200
commit57250f8deeffb892cb45a0850f0ab6ee07ccaee4 (patch)
tree81c7b4f51fa184b9fdc2b865d93c8b7a2380223c /system/modules/darwin/kresd.nix
parente9e9d0be07e91b4bb2191ad5f653e66d4f986677 (diff)
downloadnixfiles-57250f8deeffb892cb45a0850f0ab6ee07ccaee4.tar.lz
nixfiles-57250f8deeffb892cb45a0850f0ab6ee07ccaee4.tar.zst
nixfiles-57250f8deeffb892cb45a0850f0ab6ee07ccaee4.zip
nextdns: remove darwin support
Use nextdns CLI instead
Diffstat (limited to 'system/modules/darwin/kresd.nix')
-rw-r--r--system/modules/darwin/kresd.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/system/modules/darwin/kresd.nix b/system/modules/darwin/kresd.nix
deleted file mode 100644
index 6bce8af1..00000000
--- a/system/modules/darwin/kresd.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-  cfg = config.services.kresd;
-  package = pkgs.knot-resolver;
-
-  configFile = pkgs.writeText "kresd.conf" cfg.extraConfig;
-in
-{
-  options = {
-    services.kresd.enable = mkOption {
-      type = types.bool;
-      default = false;
-      description = "Whether to enable knot-resolver daemon.";
-    };
-
-    services.kresd.extraConfig = mkOption {
-      type = types.lines;
-      default = "";
-      description = ''
-        Extra configuration to be added to the generated configuration file.
-      '';
-    };
-  };
-
-  config = mkIf cfg.enable {
-    launchd.daemons.kresd = {
-      command = "${package}/bin/kresd -c ${configFile}";
-
-      serviceConfig = {
-        ProcessType = "Interactive";
-        # Sockets = {
-        #   Listeners = {
-        #     SockServiceName = "dns";
-        #     SockFamily = "IPv4";
-        #   };
-        # };
-      };
-    };
-
-    environment.systemPackages = [ package ];
-  };
-}