summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..2fa4ecf4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,21 @@
+let
+  inherit (import ./sources.nix) nixPath sources;
+
+  pkgs = import sources.nixpkgs { };
+in
+pkgs.mkShell
+{
+
+  name = "nixfiles-shell";
+
+  buildInputs = with pkgs; [
+    npins
+    fish
+    (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
+    (import sources.home-manager { inherit pkgs; }).home-manager
+  ];
+
+  shellHook = ''
+    export NIX_PATH="${builtins.concatStringsSep ":" nixPath}";
+  '';
+}