summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2025-03-02 15:18:43 +0100
committerAlan Pearce2025-03-02 23:56:41 +0100
commitb5bcdf72cbc998550bf55af1842fe65f8c9ef0bf (patch)
tree06d7f026a1d6a026aeb548cf7a920a437270d995 /shell.nix
parent734a3cebed8dd4be66a546179dbda890abc5a10d (diff)
downloadnixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.lz
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.tar.zst
nixfiles-b5bcdf72cbc998550bf55af1842fe65f8c9ef0bf.zip
Revert "Switch back to flakes"
This reverts commit c0384c43821474d28af1d9696ceb473a0d769292.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..2fa4ecf4
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,21 @@
+let
+  inherit (import ./sources.nix) nixPath sources;
+
+  pkgs = import sources.nixpkgs { };
+in
+pkgs.mkShell
+{
+
+  name = "nixfiles-shell";
+
+  buildInputs = with pkgs; [
+    npins
+    fish
+    (pkgs.callPackage "${sources.agenix}/pkgs/agenix.nix" { })
+    (import sources.home-manager { inherit pkgs; }).home-manager
+  ];
+
+  shellHook = ''
+    export NIX_PATH="${builtins.concatStringsSep ":" nixPath}";
+  '';
+}