summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 7714e111..d1270312 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,9 +3,17 @@ let
 
   nixpkgs = sources.nixpkgs;
   pkgs = import nixpkgs { };
-  lib = import ./lib { inherit pkgs; };
+  inherit (pkgs) lib;
+  # lib = import ./lib { inherit pkgs; };
+  inherit (import ./lib { inherit pkgs; }) mkNixPath fromSources;
 
-  nixPath = builtins.concatStringsSep ":" (lib.mkNixPath sources);
+  nixPath = builtins.concatStringsSep ":" (mkNixPath
+    ({
+      personal = ./packages;
+      nixpkgs-overlays = ./overlays;
+      private = ./private;
+    } // (fromSources sources))
+  );
 in
 pkgs.mkShell
 {