summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-30 17:29:18 +0200
committerAlan Pearce2024-05-30 17:29:18 +0200
commit802741a5292636b9a1619c712e128a77976e9d31 (patch)
treefaffbe342dda061f0afdb21eace0d5bc8a768d6f /shell.nix
parent15062a1bf490549f2c2a70938f6ff3a1bcbe2650 (diff)
downloadnixfiles-802741a5292636b9a1619c712e128a77976e9d31.tar.lz
nixfiles-802741a5292636b9a1619c712e128a77976e9d31.tar.zst
nixfiles-802741a5292636b9a1619c712e128a77976e9d31.zip
add local submodules to nix path
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 7714e111..d1270312 100644
--- a/shell.nix
+++ b/shell.nix
@@ -3,9 +3,17 @@ let
 
   nixpkgs = sources.nixpkgs;
   pkgs = import nixpkgs { };
-  lib = import ./lib { inherit pkgs; };
+  inherit (pkgs) lib;
+  # lib = import ./lib { inherit pkgs; };
+  inherit (import ./lib { inherit pkgs; }) mkNixPath fromSources;
 
-  nixPath = builtins.concatStringsSep ":" (lib.mkNixPath sources);
+  nixPath = builtins.concatStringsSep ":" (mkNixPath
+    ({
+      personal = ./packages;
+      nixpkgs-overlays = ./overlays;
+      private = ./private;
+    } // (fromSources sources))
+  );
 in
 pkgs.mkShell
 {