summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7abecbd5..6329ef61 100644
--- a/flake.nix
+++ b/flake.nix
@@ -43,6 +43,7 @@
       };
       homeConfigurations."alan@mba" = home-manager.lib.homeManagerConfiguration {
         pkgs = darwinPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/mba.nix
           (secrets + "/default.nix")
@@ -52,6 +53,7 @@
       };
       homeConfigurations."alan@prefect" = home-manager.lib.homeManagerConfiguration {
         pkgs = nixosPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/prefect.nix
           (secrets + "/default.nix")
@@ -61,6 +63,7 @@
       };
       homeConfigurations."alan@nanopi" = home-manager.lib.homeManagerConfiguration {
         pkgs = aarch64LinuxPackages;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/nanopi.nix
           (secrets + "/default.nix")
@@ -68,6 +71,7 @@
       };
       homeConfigurations."alan@pappel" = home-manager.lib.homeManagerConfiguration {
         pkgs = nixosPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/server.nix
           (secrets + "/default.nix")