summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-06-29 08:29:44 +0200
committerAlan Pearce2023-06-29 08:29:44 +0200
commitf14c2285e9a0213aa0beed894bfb94c837ced31f (patch)
tree322c7de1f8dba9eb722dccaf379350e9ee936bb4 /flake.nix
parent200b52fdb263cb2cf77856a70dc5fa9d05a6ad51 (diff)
downloadnixfiles-f14c2285e9a0213aa0beed894bfb94c837ced31f.tar.lz
nixfiles-f14c2285e9a0213aa0beed894bfb94c837ced31f.tar.zst
nixfiles-f14c2285e9a0213aa0beed894bfb94c837ced31f.zip
nix: automatically pin nixpkgs to flake input
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7abecbd5..6329ef61 100644
--- a/flake.nix
+++ b/flake.nix
@@ -43,6 +43,7 @@
       };
       homeConfigurations."alan@mba" = home-manager.lib.homeManagerConfiguration {
         pkgs = darwinPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/mba.nix
           (secrets + "/default.nix")
@@ -52,6 +53,7 @@
       };
       homeConfigurations."alan@prefect" = home-manager.lib.homeManagerConfiguration {
         pkgs = nixosPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/prefect.nix
           (secrets + "/default.nix")
@@ -61,6 +63,7 @@
       };
       homeConfigurations."alan@nanopi" = home-manager.lib.homeManagerConfiguration {
         pkgs = aarch64LinuxPackages;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/nanopi.nix
           (secrets + "/default.nix")
@@ -68,6 +71,7 @@
       };
       homeConfigurations."alan@pappel" = home-manager.lib.homeManagerConfiguration {
         pkgs = nixosPkgs;
+        extraSpecialArgs = { inherit attrs; };
         modules = [
           ./user/server.nix
           (secrets + "/default.nix")