summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..dff9c893
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+  inputs = {
+    nixpkgs.url = github:NixOS/nixpkgs/nixos-22.05;
+    nixpkgs-unstable.url = github:NixOS/nixpkgs;
+    nixos-hardware.url = github:NixOS/nixos-hardware;
+  };
+
+  outputs = { self, nixpkgs, nixpkgs-unstable, nixos-hardware }: {
+    nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
+      system = "x86_64-linux";
+      modules = [ ./system/prefect.nix ];
+    };
+  };
+}