summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-06-20 16:23:54 +0200
committerAlan Pearce2022-10-08 01:36:11 +0200
commit2dfb3476768af7444f94590a1ce6e5200d5cc663 (patch)
treeb3b4ff22f932a3569f8d06fb76fde72c9ba92535 /flake.nix
parent982d319d60bf0790118d4ac3debedae0ec767750 (diff)
downloadnixfiles-2dfb3476768af7444f94590a1ce6e5200d5cc663.tar.lz
nixfiles-2dfb3476768af7444f94590a1ce6e5200d5cc663.tar.zst
nixfiles-2dfb3476768af7444f94590a1ce6e5200d5cc663.zip
create initial flake.nix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..dff9c893
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+  inputs = {
+    nixpkgs.url = github:NixOS/nixpkgs/nixos-22.05;
+    nixpkgs-unstable.url = github:NixOS/nixpkgs;
+    nixos-hardware.url = github:NixOS/nixos-hardware;
+  };
+
+  outputs = { self, nixpkgs, nixpkgs-unstable, nixos-hardware }: {
+    nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
+      system = "x86_64-linux";
+      modules = [ ./system/prefect.nix ];
+    };
+  };
+}