summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index b89941a7..9115ef97 100644
--- a/flake.nix
+++ b/flake.nix
@@ -42,6 +42,7 @@
     {
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
+        specialArgs = { inherit inputs; };
         modules = [
           ./system/prefect.nix
         ] ++ (with nixos-hardware.nixosModules; [
@@ -54,10 +55,12 @@
       };
       nixosConfigurations.nanopi = nixpkgs.lib.nixosSystem {
         system = utils.lib.system.aarch64-linux;
+        specialArgs = { inherit inputs; };
         modules = [ ./nanopi.nix ];
       };
       darwinConfigurations.mba = darwin.lib.darwinSystem {
         system = utils.lib.system.aarch64-darwin;
+        specialArgs = { inherit inputs; };
         modules = [ ./system/mba.nix ];
       };
       homeConfigurations."alan@mba" = mkHomeConfiguration {