summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-10 18:50:02 +0200
committerAlan Pearce2024-04-10 18:50:02 +0200
commit2b09b74ba617346a0c9c932543e658837ef9e5d2 (patch)
tree980c05a0e50d8026a0884c6015b440c31ebb2c6f /flake.nix
parenta2534b9daab7d39d2eeb005f7648b74bc72a8520 (diff)
downloadnixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.tar.lz
nixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.tar.zst
nixfiles-2b09b74ba617346a0c9c932543e658837ef9e5d2.zip
nix: pin nixpkgs to flake input globally and per-user
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index b89941a7..9115ef97 100644
--- a/flake.nix
+++ b/flake.nix
@@ -42,6 +42,7 @@
     {
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
+        specialArgs = { inherit inputs; };
         modules = [
           ./system/prefect.nix
         ] ++ (with nixos-hardware.nixosModules; [
@@ -54,10 +55,12 @@
       };
       nixosConfigurations.nanopi = nixpkgs.lib.nixosSystem {
         system = utils.lib.system.aarch64-linux;
+        specialArgs = { inherit inputs; };
         modules = [ ./nanopi.nix ];
       };
       darwinConfigurations.mba = darwin.lib.darwinSystem {
         system = utils.lib.system.aarch64-darwin;
+        specialArgs = { inherit inputs; };
         modules = [ ./system/mba.nix ];
       };
       homeConfigurations."alan@mba" = mkHomeConfiguration {