summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 2aa1703d..dfabb683 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,7 +41,12 @@
     }:
     let
       mkHomeConfiguration = { modules, system }: home-manager.lib.homeManagerConfiguration {
-        pkgs = import nixpkgs { inherit system; };
+        pkgs = import nixpkgs {
+          inherit system;
+          overlays = [
+            self.overlays.default
+          ];
+        };
 
         inherit modules;
         extraSpecialArgs = {
@@ -50,6 +55,12 @@
       };
     in
     {
+      overlays.default = final: prev: {
+        self = {
+          htmlformat = final.callPackage ./packages/htmlformat { };
+        };
+      };
+
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = utils.lib.system.x86_64-linux;
         specialArgs = { inherit inputs; };