summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-18 14:17:43 +0200
committerAlan Pearce2024-04-18 14:17:43 +0200
commit0cee36a024bf30dd466b8245a2c4e085921a1981 (patch)
treee28b9f5ff1513d20570209d267c39c981ee88b0e /flake.nix
parentf128790d36147be1db3834b12f0ece9a766c8e06 (diff)
downloadnixfiles-0cee36a024bf30dd466b8245a2c4e085921a1981.tar.lz
nixfiles-0cee36a024bf30dd466b8245a2c4e085921a1981.tar.zst
nixfiles-0cee36a024bf30dd466b8245a2c4e085921a1981.zip
dev/web: install custom htmlformat package from self
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 2aa1703d..dfabb683 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,7 +41,12 @@
     }:
     let
       mkHomeConfiguration = { modules, system }: home-manager.lib.homeManagerConfiguration {
-        pkgs = import nixpkgs { inherit system; };
+        pkgs = import nixpkgs {
+          inherit system;
+          overlays = [
+            self.overlays.default
+          ];
+        };
 
         inherit modules;
         extraSpecialArgs = {
@@ -50,6 +55,12 @@
       };
     in
     {
+      overlays.default = final: prev: {
+        self = {
+          htmlformat = final.callPackage ./packages/htmlformat { };
+        };
+      };
+
       nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
         system = utils.lib.system.x86_64-linux;
         specialArgs = { inherit inputs; };