summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
authorAlan Pearce2020-04-03 13:27:46 +0200
committerAlan Pearce2020-04-03 13:27:46 +0200
commit7f527bb245c0dad5f827a24fe135611650ab082c (patch)
tree73cee66f282fe5b7b324299636a87510e013a0e2 /user/settings/zsh.nix
parent657f50fc07a9e65a33168cdf5451a6b05e48b651 (diff)
downloadnixfiles-7f527bb245c0dad5f827a24fe135611650ab082c.tar.lz
nixfiles-7f527bb245c0dad5f827a24fe135611650ab082c.tar.zst
nixfiles-7f527bb245c0dad5f827a24fe135611650ab082c.zip
Reorganise folder structure to remove hidden files
After moving from GNU Stow, this is not necessary.  Non-hidden files
are much easier to work with.
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index b409e728..3fb6d57d 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -28,10 +28,6 @@ in
     git-lfs
     zsh-completions
   ];
-  xdg.configFile.zsh = {
-    recursive = true;
-    source = ../zsh/.config/zsh;
-  };
 
   programs.zsh = {
     enable = true;
@@ -253,7 +249,7 @@ in
 
       source ${pkgs.fzf}/share/fzf/key-bindings.zsh
 
-    '' + builtins.readFile ../zsh/.config/zsh/.zshrc;
+    '' + builtins.readFile ../zsh/zshrc;
   };
 
   home.file."${zshrc}".onChange = "${pkgs.zsh}/bin/zsh -i -c 'autoload -Uz compinit && compinit && zcompile ${zshrc}'";