summary refs log tree commit diff stats
path: root/user/modules/tabnine.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-09-16 16:37:35 +0200
committerAlan Pearce2023-09-16 16:37:35 +0200
commitb650fde62cdef9adb55db636ce16aa2120277d55 (patch)
tree715b441b4fa07e10bec00fdc63d3a30cde2a9c33 /user/modules/tabnine.nix
parent7fd9609a559997142ecdb19a74546475344cca21 (diff)
downloadnixfiles-b650fde62cdef9adb55db636ce16aa2120277d55.tar.lz
nixfiles-b650fde62cdef9adb55db636ce16aa2120277d55.tar.zst
nixfiles-b650fde62cdef9adb55db636ce16aa2120277d55.zip
Emacs: replace company-tabnine with tabnine
Diffstat (limited to 'user/modules/tabnine.nix')
-rw-r--r--user/modules/tabnine.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/user/modules/tabnine.nix b/user/modules/tabnine.nix
index e4b80ad9..a702cf29 100644
--- a/user/modules/tabnine.nix
+++ b/user/modules/tabnine.nix
@@ -81,11 +81,11 @@ in
     };
 
     programs.emacs.extraPackages = epkgs: [
-      epkgs.company-tabnine
+      epkgs.tabnine
     ];
     programs.emacs.extraConfig = ''
-      (with-eval-after-load 'company-tabnine
-        (advice-add 'company-tabnine--executable-path :around
+      (with-eval-after-load 'tabnine
+        (advice-add 'tabnine--executable-path :around
           (lambda (original-function &rest args)
             "${pkgs.tabnine}/bin/TabNine")))
     '';