summary refs log tree commit diff stats
path: root/lib/default.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-21 07:16:52 +0200
committerAlan Pearce2024-05-21 07:16:52 +0200
commitc4309064a452a54604dac0664f8383433b762698 (patch)
treee6ed9e20e91a0d9bc0916fb7773fef7c42c68d24 /lib/default.nix
parent9d2ac307c112653091952c86bbe6797e17d0f484 (diff)
downloadnixfiles-c4309064a452a54604dac0664f8383433b762698.tar.lz
nixfiles-c4309064a452a54604dac0664f8383433b762698.tar.zst
nixfiles-c4309064a452a54604dac0664f8383433b762698.zip
lib: simplify mkPathable
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/lib/default.nix b/lib/default.nix
index 023566e5..a02fe34b 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -6,14 +6,11 @@ in
 rec {
   importPathStore = p: "${append ../. "/${p}"}";
 
-  mkPathable = s:
-    if
-      s.type == "local"
-    then
-      toString (lib.path.append ../. s.outPath)
-    else
-      toString s.outPath
-  ;
+  mkPathable = s: toString (
+    if s.type == "local"
+    then (lib.path.append ../. s.outPath)
+    else s.outPath
+  );
 
   mkNixPath = sources: lib.attrsets.mapAttrsToList
     (k: v: "${k}=${mkPathable v}")