summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-07-23 09:10:18 +0200
committerAlan Pearce2023-07-23 09:10:18 +0200
commitf99c69a24094f471bb48a9eb60994e9118da884b (patch)
tree2b70c2997a93f179562a56c8eb9eca15d77f8d2e /flake.nix
parent4a6d5f251eba3203295a09a44b3a9c86ed3c999d (diff)
downloadnixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.tar.lz
nixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.tar.zst
nixfiles-f99c69a24094f471bb48a9eb60994e9118da884b.zip
Set up lima VM running nixos
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 8e519a36..ddb4ceca 100644
--- a/flake.nix
+++ b/flake.nix
@@ -75,6 +75,15 @@
           (secrets + "/default.nix")
         ];
       };
+      homeConfigurations."alan@nixos" = home-manager.lib.homeManagerConfiguration {
+        pkgs = aarch64LinuxPackages;
+        extraSpecialArgs = { inherit attrs; };
+        modules = [
+          ./user/lima.nix
+          nix-index-database.hmModules.nix-index
+          (secrets + "/default.nix")
+        ];
+      };
       homeConfigurations."alan@pappel" = home-manager.lib.homeManagerConfiguration {
         pkgs = nixosPkgs;
         extraSpecialArgs = { inherit attrs; };