summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2022-06-25 00:55:03 +0200
committerAlan Pearce2022-10-08 01:36:11 +0200
commit02622d2b20d014ddb479365cd4d7467398dd8389 (patch)
tree7d89a55ff0443370b8f465492c9531545f1aa4be /flake.nix
parent2dfb3476768af7444f94590a1ce6e5200d5cc663 (diff)
downloadnixfiles-02622d2b20d014ddb479365cd4d7467398dd8389.tar.lz
nixfiles-02622d2b20d014ddb479365cd4d7467398dd8389.tar.zst
nixfiles-02622d2b20d014ddb479365cd4d7467398dd8389.zip
Import nixos-hardware
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index dff9c893..1249f2a9 100644
--- a/flake.nix
+++ b/flake.nix
@@ -5,9 +5,10 @@
     nixos-hardware.url = github:NixOS/nixos-hardware;
   };
 
-  outputs = { self, nixpkgs, nixpkgs-unstable, nixos-hardware }: {
+  outputs = { self, nixpkgs, ... }@attrs: {
     nixosConfigurations.prefect = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
+      specialArgs = attrs;
       modules = [ ./system/prefect.nix ];
     };
   };