summary refs log tree commit diff stats
path: root/modules/programs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/programs/shell.nix')
-rw-r--r--modules/programs/shell.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/modules/programs/shell.nix b/modules/programs/shell.nix
index b7bbd8f..d59f9fb 100644
--- a/modules/programs/shell.nix
+++ b/modules/programs/shell.nix
@@ -5,9 +5,9 @@
     promptInit = "";
   };
   programs.bash.enableCompletion = true;
+  programs.vim.enable = pkgs.stdenv.isDarwin;
 
   environment.systemPackages = with pkgs; [
-    vim
     pv
     fd
     entr
@@ -23,7 +23,11 @@
     zip
     unzip
     telnet
-
+  ] ++ (
+  if !stdenv.isDarwin
+  then [
+    vim
     unar
-  ];
+  ] else [
+  ]);
 }