summary refs log tree commit diff stats
path: root/modules/programs/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2018-11-07 16:25:15 +0100
committerAlan Pearce2018-11-07 16:25:15 +0100
commitccb69f84f6123011a176a42e0e1c50ae822d3c58 (patch)
treeb09faefb995112ebe9ec801d44addf5124733a6f /modules/programs/shell.nix
parent8003056612155a356e50829b998a0436c3d0f3a5 (diff)
parentd2c76a7b484ff11dc9a19a3e1c56bd71e9fc725f (diff)
downloadnixos-configuration-ccb69f84f6123011a176a42e0e1c50ae822d3c58.tar.lz
nixos-configuration-ccb69f84f6123011a176a42e0e1c50ae822d3c58.tar.zst
nixos-configuration-ccb69f84f6123011a176a42e0e1c50ae822d3c58.zip
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'modules/programs/shell.nix')
-rw-r--r--modules/programs/shell.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/modules/programs/shell.nix b/modules/programs/shell.nix
index b7bbd8f..d59f9fb 100644
--- a/modules/programs/shell.nix
+++ b/modules/programs/shell.nix
@@ -5,9 +5,9 @@
     promptInit = "";
   };
   programs.bash.enableCompletion = true;
+  programs.vim.enable = pkgs.stdenv.isDarwin;
 
   environment.systemPackages = with pkgs; [
-    vim
     pv
     fd
     entr
@@ -23,7 +23,11 @@
     zip
     unzip
     telnet
-
+  ] ++ (
+  if !stdenv.isDarwin
+  then [
+    vim
     unar
-  ];
+  ] else [
+  ]);
 }