summary refs log tree commit diff stats
path: root/modules/machines/t470s.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/machines/t470s.nix')
-rw-r--r--modules/machines/t470s.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/machines/t470s.nix b/modules/machines/t470s.nix
new file mode 100644
index 0000000..21614f0
--- /dev/null
+++ b/modules/machines/t470s.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+{ hardware.usbWwan.enable = true;
+  hardware.firmware = with pkgs; [
+    firmwareLinuxNonfree
+  ];
+
+  boot.blacklistedKernelModules = [ "thinkpad_acpi" ];
+
+  systemd.services.ModemManager.enable = true;
+
+  hardware.pulseaudio.extraConfig = ''
+    load-module module-alsa-sink device=hw:0,7
+  '';
+
+  environment.systemPackages = with pkgs; [
+    nvme-cli
+  ];
+
+  imports = [
+    ../hardware/intel-gpu.nix
+    ../hardware/hidpi.nix
+    ../hardware/thinkpad.nix
+  ];
+}