summary refs log tree commit diff stats
path: root/modules/machines/t470s.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-09-23 13:59:19 +0200
committerAlan Pearce2017-09-23 14:10:26 +0200
commit0f2c55992677e78d5d2908d0648e410ef9b27436 (patch)
treeb2a3432e15dd9af506c317af608ea69721979a41 /modules/machines/t470s.nix
parent496b4ed379afe7f1e0563243a0a5efe0857fe3bb (diff)
downloadnixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.lz
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.tar.zst
nixos-configuration-0f2c55992677e78d5d2908d0648e410ef9b27436.zip
Organise modules into folders
Diffstat (limited to 'modules/machines/t470s.nix')
-rw-r--r--modules/machines/t470s.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/machines/t470s.nix b/modules/machines/t470s.nix
new file mode 100644
index 0000000..21614f0
--- /dev/null
+++ b/modules/machines/t470s.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+{ hardware.usbWwan.enable = true;
+  hardware.firmware = with pkgs; [
+    firmwareLinuxNonfree
+  ];
+
+  boot.blacklistedKernelModules = [ "thinkpad_acpi" ];
+
+  systemd.services.ModemManager.enable = true;
+
+  hardware.pulseaudio.extraConfig = ''
+    load-module module-alsa-sink device=hw:0,7
+  '';
+
+  environment.systemPackages = with pkgs; [
+    nvme-cli
+  ];
+
+  imports = [
+    ../hardware/intel-gpu.nix
+    ../hardware/hidpi.nix
+    ../hardware/thinkpad.nix
+  ];
+}