summary refs log tree commit diff stats
path: root/modules/hardware/nitrokey.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hardware/nitrokey.nix')
-rw-r--r--modules/hardware/nitrokey.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/modules/hardware/nitrokey.nix b/modules/hardware/nitrokey.nix
index a0a27b0..ec25d8e 100644
--- a/modules/hardware/nitrokey.nix
+++ b/modules/hardware/nitrokey.nix
@@ -1,9 +1,5 @@
-{ config, nixpkgs, ... }:
+{ config, pkgs, ... }:
 
-let
-  pkgsUnstable = import <nixos-unstable> {};
-  # pkgsUnstable = pkgs;
-in
 { programs.ssh.startAgent = false;
 
   programs.gnupg = {
@@ -31,8 +27,8 @@ in
     };
   };
 
-  environment.systemPackages = [
-    pkgsUnstable.gnupg
-    pkgsUnstable.nitrokey-app
+  environment.systemPackages = with pkgs; [
+    gnupg
+    nitrokey-app
   ];
 }