summary refs log tree commit diff stats
path: root/modules/hardware/nitrokey.nix
diff options
context:
space:
mode:
authorAlan Pearce2017-10-18 12:41:14 +0200
committerAlan Pearce2017-10-18 12:41:14 +0200
commit140c75b83a3074c69c562fd0d788a00cad25b8e3 (patch)
treeb1d5a69aaf6ceb4dc8c93eccd8ea652b7ed3f492 /modules/hardware/nitrokey.nix
parent90ee1170898bcef3975e9f6adff5a86530ec2506 (diff)
downloadnixos-configuration-140c75b83a3074c69c562fd0d788a00cad25b8e3.tar.lz
nixos-configuration-140c75b83a3074c69c562fd0d788a00cad25b8e3.tar.zst
nixos-configuration-140c75b83a3074c69c562fd0d788a00cad25b8e3.zip
Reduce number of unstable packages installed
Diffstat (limited to 'modules/hardware/nitrokey.nix')
-rw-r--r--modules/hardware/nitrokey.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/modules/hardware/nitrokey.nix b/modules/hardware/nitrokey.nix
index a0a27b0..ec25d8e 100644
--- a/modules/hardware/nitrokey.nix
+++ b/modules/hardware/nitrokey.nix
@@ -1,9 +1,5 @@
-{ config, nixpkgs, ... }:
+{ config, pkgs, ... }:
 
-let
-  pkgsUnstable = import <nixos-unstable> {};
-  # pkgsUnstable = pkgs;
-in
 { programs.ssh.startAgent = false;
 
   programs.gnupg = {
@@ -31,8 +27,8 @@ in
     };
   };
 
-  environment.systemPackages = [
-    pkgsUnstable.gnupg
-    pkgsUnstable.nitrokey-app
+  environment.systemPackages = with pkgs; [
+    gnupg
+    nitrokey-app
   ];
 }