summary refs log tree commit diff stats
path: root/system/prefect.nix
diff options
context:
space:
mode:
authorAlan Pearce2021-01-16 20:54:31 +0100
committerAlan Pearce2021-01-16 20:56:54 +0100
commitecf61955c15b2b7e5a0f05a8be0c784b34c8b7c7 (patch)
treeaad1e1a44663008fd1b86270b75d5fb2dfddf037 /system/prefect.nix
parent15e6d3bfa4643fea6521f55563d349558e33dca9 (diff)
downloadnixfiles-ecf61955c15b2b7e5a0f05a8be0c784b34c8b7c7.tar.lz
nixfiles-ecf61955c15b2b7e5a0f05a8be0c784b34c8b7c7.tar.zst
nixfiles-ecf61955c15b2b7e5a0f05a8be0c784b34c8b7c7.zip
prefect: automount NTFS filesystems via autofs
Diffstat (limited to 'system/prefect.nix')
-rw-r--r--system/prefect.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/prefect.nix b/system/prefect.nix
index 28a5e9a6..36fc62e1 100644
--- a/system/prefect.nix
+++ b/system/prefect.nix
@@ -51,12 +51,12 @@
   fileSystems."/data" = {
     label = "Data";
     fsType = "ntfs";
-    options = ["rw" "uid=1000"];
+    options = ["rw" "uid=1000" "noauto" "x-systemd.automount"];
   };
   fileSystems."/windows" = {
-    label = "Windows";
-    fsType = "ntfs";
-    options = ["rw" "uid=1000"];
+   label = "Windows";
+   fsType = "ntfs";
+   options = ["rw" "uid=1000" "noauto" "x-systemd.automount"];
   };
 
   services.xserver = {