about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-04-17 19:59:34 +0200
committerAlan Pearce2023-04-17 19:59:34 +0200
commit72eec2299707881e9e58660467e37b777b51a632 (patch)
treebaab71f6b3e32e5dcce37f1ddfb8767f898b466f /flake.nix
downloadzola-bearblog-72eec2299707881e9e58660467e37b777b51a632.tar.lz
zola-bearblog-72eec2299707881e9e58660467e37b777b51a632.tar.zst
zola-bearblog-72eec2299707881e9e58660467e37b777b51a632.zip
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c257b2a
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+  description = "A bear blog theme for Zola";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+    flake-utils.lib.eachDefaultSystem (system:
+      let
+        pkgs = nixpkgs.legacyPackages.${system};
+      in
+      {
+        devShells.default = pkgs.mkShell {
+          packages = with pkgs; [
+            git
+            gnugrep
+            zola
+          ];
+        };
+      });
+}