about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 20 insertions, 7 deletions
diff --git a/flake.nix b/flake.nix
index c257b2a..6625f73 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,5 +1,5 @@
 {
-  description = "A bear blog theme for Zola";
+  description = "My website, alanpearce.eu";
   inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
   inputs.flake-utils.url = "github:numtide/flake-utils";
 
@@ -9,12 +9,25 @@
         pkgs = nixpkgs.legacyPackages.${system};
       in
       {
-        devShells.default = pkgs.mkShell {
-          packages = with pkgs; [
-            git
-            gnugrep
-            zola
-          ];
+        packages = {
+          default = pkgs.stdenv.mkDerivation {
+            name = "alanpearce.eu";
+            src = self;
+
+            enableParallelBuilding = true;
+            makeFlags = [ "PREFIX=$(out)" ];
+
+            nativeBuildInputs = with pkgs; [
+              zola
+              fd
+              brotli
+              gzip
+              zstd
+              git
+            ];
+
+            dontFixup = true;
+          };
         };
       });
 }