about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-11-16 13:11:06 +0100
committerAlan Pearce2024-11-16 13:11:06 +0100
commit72018b5585e945aa51a3a557a641cce17cabaf26 (patch)
tree5dfaa8c99fba0cb233192097273931d7d148f7d7 /shell.nix
parentcd04ffd199e989f233797d18013fe35380b0376d (diff)
downloadwebsite-72018b5585e945aa51a3a557a641cce17cabaf26.tar.lz
website-72018b5585e945aa51a3a557a641cce17cabaf26.tar.zst
website-72018b5585e945aa51a3a557a641cce17cabaf26.zip
Switch back to flakes
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 4b62685..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ pkgs ? (
-    let
-      sources = import ./npins;
-    in
-    import sources.nixpkgs { }
-  )
-}:
-let
-  inherit (import ./.) pre-commit-check;
-in
-pkgs.mkShell {
-  inherit (pre-commit-check) shellHook;
-  packages = with pkgs; [
-    go
-    npins
-    gopls
-    go-licenses
-    gotools
-    templ
-    hyperlink
-    systemfd
-    just
-    modd
-  ];
-}